All Systems Operational
newVoice VoIP network Operational
90 days ago
100.0 % uptime
Today
UCaaS calling services Operational
90 days ago
100.0 % uptime
Today
SIP calling services Operational
90 days ago
100.0 % uptime
Today
Commportal dashboard Operational
UCaaS App services ? Operational
newVoice Legacy VoIP Network Operational
90 days ago
100.0 % uptime
Today
nhc.v SD-WAN Network Operational
90 days ago
100.0 % uptime
Today
nhc.v SD-WAN VCO 124 ? Operational
nhc.v SD-WAN VCO 129 ? Operational
90 days ago
100.0 % uptime
Today
nhc.v SD-WAN VCO 160 ? Operational
nhc.m MAP Customer Portal ? Operational
nhc Carrier Networks Operational
nhc Network ? Operational
nhc VoIP IP Carrier Network ? Operational
Operational
Degraded Performance
Partial Outage
Major Outage
Maintenance
Major outage
Partial outage
No downtime recorded on this day.
No data exists for this day.
had a major outage.
had a partial outage.
Scheduled Maintenance
NHC will be implementing changes to our newVoice platform.

Change Control # (191142)

During this maintenance window NHC engineers will be performing upgrades to support continued optimization and improvement of our calling services. 

If there is any interruption in service we expect it to be brief as the maintenance is not anticipated to be service affecting.  NHC will be closely monitoring services during the maintenance.

Please refer any questions to:
NHC Operations Center
repair@nhcgrp.com
855-600-4NHC

Posted on May 01, 2024 - 10:35 EDT
NHC will be implementing changes to our newVoice platform.

Change Control # (191142)

During this maintenance window NHC engineers will be performing upgrades to support continued optimization and improvement of our calling services. 

If there is any interruption in service we expect it to be brief as the maintenance is not anticipated to be service affecting.  NHC will be closely monitoring services during the maintenance.

Please refer any questions to:
NHC Operations Center
repair@nhcgrp.com
855-600-4NHC

Posted on May 01, 2024 - 10:36 EDT
NHC will be implementing changes to our newVoice platform.

Change Control # (191142)

During this maintenance window NHC engineers will be performing upgrades to support continued optimization and improvement of our calling services. 

If there is any interruption in service we expect it to be brief as the maintenance is not anticipated to be service affecting.  NHC will be closely monitoring services during the maintenance.

Please refer any questions to:
NHC Operations Center
repair@nhcgrp.com
855-600-4NHC

Posted on May 01, 2024 - 10:36 EDT
Past Incidents
May 2, 2024

No incidents reported today.

May 1, 2024
Completed - The scheduled maintenance has been completed.
May 1, 04:00 EDT
In progress - Scheduled maintenance is currently in progress. We will provide updates as necessary.
May 1, 00:00 EDT
Scheduled - NHC will be implementing changes to our newVoice platform.

Change Control # (190086)

During this maintenance window NHC engineers will be performing upgrades to support continued optimization and improvement of our calling services. 

If there is any interruption in service we expect it to be brief as the maintenance is not anticipated to be service affecting.  NHC will be closely monitoring services during the maintenance.

Please refer any questions to:
NHC Operations Center
repair@nhcgrp.com
855-600-4NHC

Apr 17, 16:58 EDT
Apr 30, 2024
Completed - The scheduled maintenance has been completed.
Apr 30, 04:00 EDT
In progress - Scheduled maintenance is currently in progress. We will provide updates as necessary.
Apr 30, 00:00 EDT
Scheduled - NHC will be implementing changes to our newVoice platform.

Change Control # (190086

During this maintenance window NHC engineers will be performing upgrades to support continued optimization and improvement of our calling services. 

If there is any interruption in service we expect it to be brief as the maintenance is not anticipated to be service affecting.  NHC will be closely monitoring services during the maintenance.

Please refer any questions to:
NHC Operations Center
repair@nhcgrp.com
855-600-4NHC

Apr 17, 16:57 EDT
Apr 29, 2024

No incidents reported.

Apr 28, 2024

No incidents reported.

Apr 27, 2024

No incidents reported.

Apr 26, 2024

No incidents reported.

Apr 25, 2024

No incidents reported.

Apr 24, 2024

No incidents reported.

Apr 23, 2024

No incidents reported.

Apr 22, 2024

No incidents reported.

Apr 21, 2024

No incidents reported.

Apr 20, 2024

No incidents reported.

Apr 19, 2024

No incidents reported.

Apr 18, 2024

No incidents reported.